Lawrence Livermore National Laboratory



23. Which compilers can be used to build VisIt?

The following compilers can be used to build VisIt on the listed platforms, though this is not an exhaustive list and newer versions of these compilers often work. In general, any g++ 4.x series compiler will build VisIt just fine. Earlier versions of g++ will also usually work.

Platform Compiler
AIX 5.3 xlC
Linux g++ 4.0 or later
Windows XP,Vista,7 Microsoft Visual Studio .Net 2003, or .Net 2005 (Visual Studio 2010 support coming)
MacOS X 10.4-10.6 g++ 4.0 or later